Автор Тема: Установка свободного ПО на Макинтош. Проблема с gettext.  (Прочитано 1210 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Онлайн Владимир Витальевич

  • Сообщений: 32776
    • Не указано
Здравствуйте. Вопрос юниксоидам и/или маководам.


Попробовал установить на макос 1.6.8 программу Kile из исходников с помощью Fink. Но какая конкретно программа не так важно. Проблема в том, что не устанавливается пакет locale-gettext (в версии locale-gettext-pl5100). Лично мне он нафик не нужен, т.к. вполне бы подошли бы не локализованные версии ПО. Но большинство перловых пакетов эту фигню требуют (и не факт, что поможет отключение проверки зависимостей). А она сама требует установленный gettext и библиотеку libintl. Всё это стоит, но сценарий установки не видит библиотеки и вылетает. Попытка отключить сценарий проверки руками не помогает: fink выкидывает при несоответствии MD5 контрольной сумме. Но и неизвестно, увидит ли он библиотеку после. Может быть надо как-то её прописать иначе или куда-то положить. Или он внутри библиотеки что-то не то находит?


Погуглив обнаружил, что похожая проблема встречалась в убунтах, но как её решить на маке, непонятно. Если кто рубит, могу выложить куски лога и проблемное место в сценарии.


Без этой дряни почти никакое ПО не встанет.

 

Пожертвования на работу форума "Православное кафе 'Миссионер'"
можно отправлять по приведенным ниже реквизитам"

R412396415730
E210633234893
Z101437155470

41001985760841



Рейтинг@Mail.ru